[RELEASE] Version 3.1.0

With this release, a version bug has been fixed. Since b4d96a72 it's necessary to run the Python script with at least Python version 3.6 (and not version 3.5 as it was claimed before). This information has now been added to the documentation. Additionally, support of Travis CI has been added to the repository in order to test core functionalities of the project.